GPU Help needed

haroonshaikh

Moderator
Moderator
Jul 27, 2007
3,089
9
44
32
Karachi
Salam guys,

Recently I have been facing some issues related to my Graphic card. I currently own a Sapphire HD 7950 3Gb video card. For the past 2 weeks, the problem is that computer would start normally but then the display would go off suddenly after 4-5 minutes. I can also try starting a game which would start normally but just after 4-5 minutes, the screen would go black and rest all peripherals would continue to work. When I switched to on-board graphics, the problem disappeared.

I tried monitoring temperatures of my card which are normal ( Considering my old GPU Fan died and installed an aftermarket fan in its place 2 years ago), I tried cleaning the slot, making sure wire connections are fine but no result.. Now, friends, can anyone help me please what is wrong with my PC ?? Should i consider reinstalling drivers ?? or it might be a windows 10 issue? Physically the card looks 100% all right .
 

nafu

Senior
Jan 25, 2010
6,444
6
43
32
Islamabad
docs.google.com
Salam guys,

Recently I have been facing some issues related to my Graphic card. I currently own a Sapphire HD 7950 3Gb video card. For the past 2 weeks, the problem is that computer would start normally but then the display would go off suddenly after 4-5 minutes. I can also try starting a game which would start normally but just after 4-5 minutes, the screen would go black and rest all peripherals would continue to work. When I switched to on-board graphics, the problem disappeared.

I tried monitoring temperatures of my card which are normal ( Considering my old GPU Fan died and installed an aftermarket fan in its place 2 years ago), I tried cleaning the slot, making sure wire connections are fine but no result.. Now, friends, can anyone help me please what is wrong with my PC ?? Should i consider reinstalling drivers ?? or it might be a windows 10 issue? Physically the card looks 100% all right .
Wslam,

Hey, Haroon, I also experience same kind of issue with HD 7850, a long time ago. There were frequent blackouts on my GPU while it was being running. All the components were running including GPU's fan. Later, I found it's old generation board that causing problem. I changed board to newer model and the problem gone. So, sometimes generation or model conflicts brings a trouble. I am assuming you're using this GPU from a long time on the same board, so I don't think you have the same problem. But who knows.

Let's comes to the possible cause. My first impression to your problem, is the GPU being old now and prolly in its last breath.
But before you say goodbye to this oldie, you might need to test 7950 with latest drivers or changing to a stable one. Sometimes, old drivers could give you trouble. So, give a try. In addition, you could try this gpu on different MOTHERBOARD. Should check the POWER SUPPLY you're using. If it's still 100%.

Well, Windows 10, I am sure about it.
 

haroonshaikh

Moderator
Moderator
Jul 27, 2007
3,089
9
44
32
Karachi
Wslam,

Hey, Haroon, I also experience same kind of issue with HD 7850, a long time ago. There were frequent blackouts on my GPU while it was being running. All the components were running including GPU's fan. Later, I found it's old generation board that causing problem. I changed board to newer model and the problem gone. So, sometimes generation or model conflicts brings a trouble. I am assuming you're using this GPU from a long time on the same board, so I don't think you have the same problem. But who knows.

Let's comes to the possible cause. My first impression to your problem, is the GPU being old now and prolly in its last breath.
But before you say goodbye to this oldie, you might need to test 7950 with latest drivers or changing to a stable one. Sometimes, old drivers could give you trouble. So, give a try. In addition, you could try this gpu on different MOTHERBOARD. Should check the POWER SUPPLY you're using. If it's still 100%.

Well, Windows 10, I am sure about it.
Now that you mentioned, I did have problems with my previous AsRock Motherboard which i disposed off. I bought new ASUS ( cheapest model) available just to get the GPU working. For the past 1 year or so. every 2 months i would face sudden blackout of screen. I would dust off my PC, remove and put all components back in
and eventually the PC would work for next few weeks. In-fact, I even changed my monitor 3 months back thinking its the culprit. I will try updating the drivers and check my power supply output. meanwhile I will look for someone to test out my GPU. The thing is 7950 is an amazing card. I have overclocked it from base clock of 800 to 1150 for benchmarking purpose. I just cannot believe my 45k going to waste. ( bought in the month of release)
 

nafu

Senior
Jan 25, 2010
6,444
6
43
32
Islamabad
docs.google.com
Haroon, I think this would not be a waste. The number of years it has been used in your PC is impressive, to say the least. It paid off well.

Check psu functionality and motherboard as well.

Sent from my Lenovo S850 using Tapatalk
 

beret21

Well-known member
Oct 25, 2012
1,342
5
44
Now that you mentioned, I did have problems with my previous AsRock Motherboard which i disposed off. I bought new ASUS ( cheapest model) available just to get the GPU working. For the past 1 year or so. every 2 months i would face sudden blackout of screen. I would dust off my PC, remove and put all components back in
and eventually the PC would work for next few weeks. In-fact, I even changed my monitor 3 months back thinking its the culprit. I will try updating the drivers and check my power supply output. meanwhile I will look for someone to test out my GPU. The thing is 7950 is an amazing card. I have overclocked it from base clock of 800 to 1150 for benchmarking purpose. I just cannot believe my 45k going to waste. ( bought in the month of release)
I had a gigabyte h61 mobo that had GPU compatibility issue. Although theoretically it was pcie gen 2.0 supported ( even if it is or not still it should, handle all PCIE cards ). The problem with that mobo was that it wont handle older GPUs. Like the AMD 6xxx series. Gigabyte released a BIOS update but the problem wasnt resolved.
So my suggestion is to check for a BIOS update ( it might help )
Second thing is that the budget H61 boards are really BAD. I have seen sooo many cases of RAM slots gone faulty, GPUs not working properly n CPU throttling. The issues with these boards is that they are not made good enough to handle high current ( like the heavy GPUs and CPUs ). Filtering is also poor which shortens your hardware lifespan.
 

haroonshaikh

Moderator
Moderator
Jul 27, 2007
3,089
9
44
32
Karachi
Update, So the problem so far was that the PC was not booting up with dedicated GPU. after searching the internet for hours. I finally updated my motherboard BIOS. That did not solve the problem.
Next thinking that it is a windows 10 issue. i deleted all previous AMD Drivers and removed all recent windows updates. Put the graphic card back in slot and it booted. But it was working without dedicated drivers giving only the basic display. I downloaded and used latest AMD Drivers. So the GPU was working fine as long as I was browsing. As soon as I started a game, screen went black.
I downloaded Furmark to stress test GPU but again as soon as i pressed the Start button, screen went black..

All these point towards GPU failure, I just want to make sure that there are no other faulty components before i change my GPU.
 

nafu

Senior
Jan 25, 2010
6,444
6
43
32
Islamabad
docs.google.com
Update, So the problem so far was that the PC was not booting up with dedicated GPU. after searching the internet for hours. I finally updated my motherboard BIOS. That did not solve the problem.
Next thinking that it is a windows 10 issue. i deleted all previous AMD Drivers and removed all recent windows updates. Put the graphic card back in slot and it booted. But it was working without dedicated drivers giving only the basic display. I downloaded and used latest AMD Drivers. So the GPU was working fine as long as I was browsing. As soon as I started a game, screen went black.
I downloaded Furmark to stress test GPU but again as soon as i pressed the Start button, screen went black..

All these point towards GPU failure, I just want to make sure that there are no other faulty components before i change my GPU.
Very unfortunate and now it's confirmed. But it's a good reason to upgrade your GPU. At this point, I am expecting at least GTX 1070 from you. :D
keep 7950 for future experiments.
 

haroonshaikh

Moderator
Moderator
Jul 27, 2007
3,089
9
44
32
Karachi
Very unfortunate and now it's confirmed. But it's a good reason to upgrade your GPU. At this point, I am expecting at least GTX 1070 from you. :D
keep 7950 for future experiments.
Considering my busy routine and financial constraints, i think i will have to settle for 470. I still use my old DELL monitor with 1600 resolution so it will suffice. But would my 2500k bottleneck performance. ? I am also thinking to upgrade my PC Casing. Its a mid tower but due to presence of non modular PSU and the Aerocool fan cooler, its jam packed with haphazard wires and all. what cost effective solution would you recommend ?
 

beret21

Well-known member
Oct 25, 2012
1,342
5
44
Update, So the problem so far was that the PC was not booting up with dedicated GPU. after searching the internet for hours. I finally updated my motherboard BIOS. That did not solve the problem.
Next thinking that it is a windows 10 issue. i deleted all previous AMD Drivers and removed all recent windows updates. Put the graphic card back in slot and it booted. But it was working without dedicated drivers giving only the basic display. I downloaded and used latest AMD Drivers. So the GPU was working fine as long as I was browsing. As soon as I started a game, screen went black.
I downloaded Furmark to stress test GPU but again as soon as i pressed the Start button, screen went black..

All these point towards GPU failure, I just want to make sure that there are no other faulty components before i change my GPU.
Well it can be that your PSU is faulty and as soon as your GPU gets Load it cant deliver the amps required. I came up with this because GPU has 2D and 3D clocks and on 3D clocks ( while gaming or 3D stuff ) the GPU requires much much more power than that when its on 2D ... There are still greater chances that your GPU is the culprit but we cant just rule out this possibility. Best way to check it will be to give your GPU to a friend or neighbor to check on his system if possible.
 

nafu

Senior
Jan 25, 2010
6,444
6
43
32
Islamabad
docs.google.com
Considering my busy routine and financial constraints, i think i will have to settle for 470. I still use my old DELL monitor with 1600 resolution so it will suffice. But would my 2500k bottleneck performance. ? I am also thinking to upgrade my PC Casing. Its a mid tower but due to presence of non modular PSU and the Aerocool fan cooler, its jam packed with haphazard wires and all. what cost effective solution would you recommend ?
I don't think an i5 2500K or any 4 core processor will bottleneck in gaming.

For chassis, it will depends on your budget. Corsair has a lot of market in Pakistan, mostly the budgeted PC cases. I am using Full Tower 750D and is quite spacious, I am settled with it.
So, I would also recommend you the same, but then it's your budget that will decide which case is in your reach.
 
Last edited:

haroonshaikh

Moderator
Moderator
Jul 27, 2007
3,089
9
44
32
Karachi
Well it can be that your PSU is faulty and as soon as your GPU gets Load it cant deliver the amps required. I came up with this because GPU has 2D and 3D clocks and on 3D clocks ( while gaming or 3D stuff ) the GPU requires much much more power than that when its on 2D ... There are still greater chances that your GPU is the culprit but we cant just rule out this possibility. Best way to check it will be to give your GPU to a friend or neighbor to check on his system if possible.
This is exactly what i want to exclude before i buy a new GPU.
 
General chit-chat
Help Users
We have disabled traderscore and are working on a fix. There was a bug with the plugin
    Major Aly Major Aly: tbh i have no intention to replay it lol 🤣 🤣 🤣 🤣